use strict;
my $str = 'switch (count + t - (fdg + fsd))
{
case 1:
{
яячсячсячс ываы
break;
}
case 2:
{
cout << a << " - " << b << " = " << a - b << endl; // выполнить вычитание
break;
}
case 3:
{
cout << a << " * " << b << " = " << a * b << endl; // выполнить умножение
break;
}
case 4:
{
cout << a << " / " << b << " = " << a / b << endl; // выполнить деление
break;
}
}';
my $regex = qr/(?:switch\s*\((?P<conditional>(?:(?:(?:"(?:(?:\\")|[^"])*")|(?:'(?:(?:\\')|[^'])*'))|[^\(\)]|\((?1)\))*)\)\s*{)*(?:(?:\s*(?:case(?P<value>.*?):?\s*{(?P<body>(?:(?:(?:"(?:(?:\\")|[^"])*")|(?:'(?:(?:\\')|[^'])*'))|[^{}]|{(?2)})*)\s*}))+?)|(?:default:\s*{(?P<default_body>(?:(?:(?:"(?:(?:\\")|[^"])*")|(?:'(?:(?:\\')|[^'])*'))|[^{}]|{(?1)})*)\s*}\s*)?}/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}