re = /(?:switch\s*\((?P<conditional>(?:(?:(?:"(?:(?:\\")|[^"])*")|(?:'(?:(?:\\')|[^'])*'))|[^\(\)]|\((?1)\))*)\)\s*{)*(?:(?:\s*(?:case(?P<value>.*?):?\s*{(?P<body>(?:(?:(?:"(?:(?:\\")|[^"])*")|(?:'(?:(?:\\')|[^'])*'))|[^{}]|{(?2)})*)\s*}))+?)|(?:default:\s*{(?P<default_body>(?:(?:(?:"(?:(?:\\")|[^"])*")|(?:'(?:(?:\\')|[^'])*'))|[^{}]|{(?1)})*)\s*}\s*)?}/im
str = 'switch (count + t - (fdg + fsd))
{
case 1:
{
яячсячсячс ываы
break;
}
case 2:
{
cout << a << " - " << b << " = " << a - b << endl; // выполнить вычитание
break;
}
case 3:
{
cout << a << " * " << b << " = " << a * b << endl; // выполнить умножение
break;
}
case 4:
{
cout << a << " / " << b << " = " << a / b << endl; // выполнить деление
break;
}
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end