package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/([^_\/]+)(?:_([^_\/]+)?_?)?(?:_([^_\/]+)?_?)?(?:_([^_\/]+)?_?)?\/$`)
var str = `/some_url/price_desc_30_list/
/some_url/_30/
/some_url/30/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}