re = /\/([^_\/]+)(?:_([^_\/]+)?_?)?(?:_([^_\/]+)?_?)?(?:_([^_\/]+)?_?)?\/$/m
str = '/some_url/price_desc_30_list/
/some_url/_30/
/some_url/30/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end