import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/([^_\\/]+)(?:_([^_\\/]+)?_?)?(?:_([^_\\/]+)?_?)?(?:_([^_\\/]+)?_?)?\\/$";
final String string = "/some_url/price_desc_30_list/\n"
+ "/some_url/_30/\n"
+ "/some_url/30/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}