#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "path(?:.*?foo=(\d+)\b|()(?!.*foo))"
Local $sString = "path?foo=67" & @CRLF & _
"path?foo=67&bar=hello" & @CRLF & _
"path?bar=bye&foo=1&baz=12" & @CRLF & _
"path?bar=123" & @CRLF & _
"path" & @CRLF & _
"path?foo=37signals" & @CRLF & _
"path?foo=-8" & @CRLF & _
"something?foo=1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")