using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"path(?:.*?foo=(\d+)\b|()(?!.*foo))";
string input = @"path?foo=67
path?foo=67&bar=hello
path?bar=bye&foo=1&baz=12
path?bar=123
path
path?foo=37signals
path?foo=-8
something?foo=1";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}