import re
regex = re.compile(r"path(?:.*?foo=(\d+)\b|()(?!.*foo))")
test_str = ("path?foo=67\n"
"path?foo=67&bar=hello\n"
"path?bar=bye&foo=1&baz=12\n"
"path?bar=123\n"
"path\n"
"path?foo=37signals\n"
"path?foo=-8\n"
"something?foo=1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")