$re = '/path(?:.*?foo=(\d+)\b|()(?!.*foo))/';
$str = 'path?foo=67
path?foo=67&bar=hello
path?bar=bye&foo=1&baz=12
path?bar=123
path
path?foo=37signals
path?foo=-8
something?foo=1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);