const regex = new RegExp('(January|February|March|April|May|June|July|August|September|October|November|December)[ ](0[1-9]|[1-2][0-9]|3[0-1])[,][ ](20)[0-9]{2}', '')
const str = `The owners of this address received a permit on Wednesday, June 14, 2013
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}