$re = '/(January|February|March|April|May|June|July|August|September|October|November|December)[ ](0[1-9]|[1-2][0-9]|3[0-1])[,][ ](20)[0-9]{2}/';
$str = 'The owners of this address received a permit on Wednesday, June 14, 2013
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);