// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(January|February|March|April|May|June|July|August|September|October|November|December)[ ](0[1-9]|[1-2][0-9]|3[0-1])[,][ ](20)[0-9]{2}").unwrap();
let string = "The owners of this address received a permit on Wednesday, June 14, 2013
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}