const regex = /\[(.*?)\|(.*?)\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(.*?)\\|(.*?)\\]', 'g')
const str = `gewgweg ewwegoih #ihogewig #CorporateRaid [durov|Дуров]
Wsasd asdff [somebody|Кто-то] #HIii`;
const subst = `$2 (vk.com/$1)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);