$re = '/\[(.*?)\|(.*?)\]/';
$str = 'gewgweg ewwegoih #ihogewig #CorporateRaid [durov|Дуров]
Wsasd asdff [somebody|Кто-то] #HIii';
$subst = "$2 (vk.com/$1)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;