import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(data-hora)>(\\d{4}-\\d{2}-\\d{2})T(\\d{2}:\\d{2}:\\d{2})[\\d\\-\\.:]*<\\/\\1>";
final String string = "<data-hora>2015-11-10T11:33:41.086-02:00</data-hora>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}