const regex = /<(data-hora)>(\d{4}-\d{2}-\d{2})T(\d{2}:\d{2}:\d{2})[\d\-\.:]*<\/\1>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(data-hora)>(\\d{4}-\\d{2}-\\d{2})T(\\d{2}:\\d{2}:\\d{2})[\\d\\-\\.:]*<\\\/\\1>', '')
const str = `<data-hora>2015-11-10T11:33:41.086-02:00</data-hora>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}