import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@([\\w]+)";
final String string = "@galaxy5univ I like you\n"
+ "RT @BestOfGalaxies: Let's sit under the stars ...\n"
+ "@jonghyun__bot .........((thanks)\n"
+ "RT @yosizo: thanks.ddddd <https://yahoo.com>\n"
+ "RT @LDH_3_yui: #fam, ccccc https://msn.news.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}