import re
regex = re.compile(r"@([\w]+)", flags=re.MULTILINE)
test_str = ("@galaxy5univ I like you\n"
"RT @BestOfGalaxies: Let's sit under the stars ...\n"
"@jonghyun__bot .........((thanks)\n"
"RT @yosizo: thanks.ddddd <https://yahoo.com>\n"
"RT @LDH_3_yui: #fam, ccccc https://msn.news.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")