// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)@([\w]+)").unwrap();
let string = "@galaxy5univ I like you
RT @BestOfGalaxies: Let's sit under the stars ...
@jonghyun__bot .........((thanks)
RT @yosizo: thanks.ddddd <https://yahoo.com>
RT @LDH_3_yui: #fam, ccccc https://msn.news.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}