#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)/hello/world/(\d{1,6})\b"
Local $sString = "Matching:" & @CRLF & _
"" & @CRLF & _
"/hello/world/123" & @CRLF & _
"/hello/world/123/" & @CRLF & _
"/hello/world/123?query_arg=what;" & @CRLF & _
"/hello/world/123/?huh=what " & @CRLF & _
"" & @CRLF & _
"Not matching:" & @CRLF & _
"" & @CRLF & _
"/hello/world/letters/" & @CRLF & _
"/hello/world/1234567/too-many-digits" & @CRLF & _
"/goodbye/world/123/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")