re = /\/hello\/world\/(\d{1,6})\b/m
str = 'Matching:
/hello/world/123
/hello/world/123/
/hello/world/123?query_arg=what;
/hello/world/123/?huh=what
Not matching:
/hello/world/letters/
/hello/world/1234567/too-many-digits
/goodbye/world/123/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end