// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)/hello/world/(\d{1,6})\b").unwrap();
let string = "Matching:
/hello/world/123
/hello/world/123/
/hello/world/123?query_arg=what;
/hello/world/123/?huh=what
Not matching:
/hello/world/letters/
/hello/world/1234567/too-many-digits
/goodbye/world/123/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}