using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/hello/world/(\d{1,6})\b";
string input = @"Matching:
/hello/world/123
/hello/world/123/
/hello/world/123?query_arg=what;
/hello/world/123/?huh=what
Not matching:
/hello/world/letters/
/hello/world/1234567/too-many-digits
/goodbye/world/123/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}