package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(First Name) +(\S+)|(Last Name) +(\S+)|(City) +(\S+)`)
var str = `First Name Guilherme
Last Name Souza
City Piracicaba`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}