re = /(First Name) +(\S+)|(Last Name) +(\S+)|(City) +(\S+)/m
str = 'First Name Guilherme
Last Name Souza
City Piracicaba'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end