$re = '/(First Name) +(\S+)|(Last Name) +(\S+)|(City) +(\S+)/m';
$str = 'First Name Guilherme
Last Name Souza
City Piracicaba';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);