using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\Q<li id=""\E([^""]*)\Q"" data-asin=""\E([a-zA-Z0-9<> ]{8,})\Q"">\E(.*)\Q</li>\E";
string input = @"<li id=""result_0"" data-asin=""<8 char hash>""> ........ </li>
<li id=""result_1"" data-asin=""<8 char hash>""> ........ </li>
<li id=""result_2"" data-asin=""<8 char hash>""> ........ </li>
<li id=""result_3"" data-asin=""<8 char hash>""> ........ </li>
<li id=""result_4"" data-asin=""<8 char hash>""> ........ </li>
....
<li id=""result_15"" data-asin=""<8 char hash>""> ........ </li>
<li id=""result_16"" data-asin=""<8 char hash>""> ........ </li>
<li id=""result_17"" data-asin=""<8 char hash>""> ........ </li>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}