// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\Q<li id="\E([^"]*)\Q" data-asin="\E([a-zA-Z0-9<> ]{8,})\Q">\E(.*)\Q</li>\E"#).unwrap();
let string = "<li id=\"result_0\" data-asin=\"<8 char hash>\"> ........ </li>
<li id=\"result_1\" data-asin=\"<8 char hash>\"> ........ </li>
<li id=\"result_2\" data-asin=\"<8 char hash>\"> ........ </li>
<li id=\"result_3\" data-asin=\"<8 char hash>\"> ........ </li>
<li id=\"result_4\" data-asin=\"<8 char hash>\"> ........ </li>
....
<li id=\"result_15\" data-asin=\"<8 char hash>\"> ........ </li>
<li id=\"result_16\" data-asin=\"<8 char hash>\"> ........ </li>
<li id=\"result_17\" data-asin=\"<8 char hash>\"> ........ </li>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}