package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\Q<li id="\E([^"]*)\Q" data-asin="\E([a-zA-Z0-9<> ]{8,})\Q">\E(.*)\Q</li>\E`)
var str = `<li id="result_0" data-asin="<8 char hash>"> ........ </li>
<li id="result_1" data-asin="<8 char hash>"> ........ </li>
<li id="result_2" data-asin="<8 char hash>"> ........ </li>
<li id="result_3" data-asin="<8 char hash>"> ........ </li>
<li id="result_4" data-asin="<8 char hash>"> ........ </li>
....
<li id="result_15" data-asin="<8 char hash>"> ........ </li>
<li id="result_16" data-asin="<8 char hash>"> ........ </li>
<li id="result_17" data-asin="<8 char hash>"> ........ </li>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}