import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\Q<li id=\"\\E([^\"]*)\\Q\" data-asin=\"\\E([a-zA-Z0-9<> ]{8,})\\Q\">\\E(.*)\\Q</li>\\E";
final String string = "<li id=\"result_0\" data-asin=\"<8 char hash>\"> ........ </li>\n"
+ "<li id=\"result_1\" data-asin=\"<8 char hash>\"> ........ </li>\n"
+ "<li id=\"result_2\" data-asin=\"<8 char hash>\"> ........ </li>\n"
+ "<li id=\"result_3\" data-asin=\"<8 char hash>\"> ........ </li>\n"
+ "<li id=\"result_4\" data-asin=\"<8 char hash>\"> ........ </li>\n"
+ "....\n"
+ "<li id=\"result_15\" data-asin=\"<8 char hash>\"> ........ </li>\n"
+ "<li id=\"result_16\" data-asin=\"<8 char hash>\"> ........ </li>\n"
+ "<li id=\"result_17\" data-asin=\"<8 char hash>\"> ........ </li>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}