import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=\\S{10,})(?=\\S*[A-Z])(?=\\S*[a-z])(?=\\S*[0-9])(?=\\S*[!£$%^&\\\"])(?<!\\S)\\S{10,20}(?=\\s|\\Z)";
final String string = "Password!123\n"
+ "Password!123 test test\n"
+ "test \"Password!123\" test test\n\n"
+ " 9: Abc!56789\n"
+ "10: -Ab!567890\n"
+ "20: -Ab!567890DeF4567890\n"
+ "21: AbC!567890DeF45678901\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}