$re = '/(?=\S{10,})(?=\S*[A-Z])(?=\S*[a-z])(?=\S*[0-9])(?=\S*[!£$%^&\"])(?<!\S)\S{10,20}(?=\s|\Z)/';
$str = 'Password!123
Password!123 test test
test "Password!123" test test
9: Abc!56789
10: -Ab!567890
20: -Ab!567890DeF4567890
21: AbC!567890DeF45678901
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);