import re
regex = re.compile(r"(?=\S{10,})(?=\S*[A-Z])(?=\S*[a-z])(?=\S*[0-9])(?=\S*[!£$%^&\"])(?<!\S)\S{10,20}(?=\s|\Z)")
test_str = ("Password!123\n"
"Password!123 test test\n"
"test \"Password!123\" test test\n\n"
" 9: Abc!56789\n"
"10: -Ab!567890\n"
"20: -Ab!567890DeF4567890\n"
"21: AbC!567890DeF45678901\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")