# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\w+(?=\()|\b[xy]\b/X/g;t' <<< "def gcd(x, y):
\"\"\"Sample docstring.\"\"\"
if x == y:
return x
if x > y:
if y == 0: return x
return gcd(x-y, y)
if y > x:
if x == 0: return y
# Sample comment.
return gcd(x, y-x)"