using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+(?=\()|\b[xy]\b";
string substitution = @"X";
string input = @"def gcd(x, y):
""""Sample docstring.""""
if x == y:
return x
if x > y:
if y == 0: return x
return gcd(x-y, y)
if y > x:
if x == 0: return y
# Sample comment.
return gcd(x, y-x)";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}