re = /\w+(?=\()|\b[xy]\b/
str = 'def gcd(x, y):
"""Sample docstring."""
if x == y:
return x
if x > y:
if y == 0: return x
return gcd(x-y, y)
if y > x:
if x == 0: return y
# Sample comment.
return gcd(x, y-x)'
subst = 'X'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result