#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\w+(?=\()|\b[xy]\b"
Local $sString = "def gcd(x, y):" & @CRLF & _
""""Sample docstring."""" & @CRLF & _
"if x == y:" & @CRLF & _
" return x" & @CRLF & _
"if x > y:" & @CRLF & _
" if y == 0: return x" & @CRLF & _
" return gcd(x-y, y)" & @CRLF & _
"if y > x:" & @CRLF & _
" if x == 0: return y" & @CRLF & _
" # Sample comment." & @CRLF & _
" return gcd(x, y-x)"
Local $sSubst = "X"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)