#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)^.*(\S*)\({1}.*ref\s*SqlConnection"
Local $sString = "public static bool InsertNote(string TableName, string TableKey, string DocType, string InsuredKey, string SubmissionKey," & @CRLF & _
" string Staff, string DefaultAction, string DisplayKey, FileType FileType, string IFSFileName," & @CRLF & _
" string IFSFolder, string IFSTimeStamp, string Subject, string Notation, NoteType NoteType," & @CRLF & _
" //string Company, string NoteCategory, ref OracleConnection Connection)" & @CRLF & _
" string Company, string NoteCategory, string DocumentName, ref SqlConnection Connection)" & @CRLF & _
" {"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")