import re
regex = re.compile(r"^.*(\S*)\({1}.*ref\s*SqlConnection", flags=re.DOTALL)
test_str = ("public static bool InsertNote(string TableName, string TableKey, string DocType, string InsuredKey, string SubmissionKey,\n"
" string Staff, string DefaultAction, string DisplayKey, FileType FileType, string IFSFileName,\n"
" string IFSFolder, string IFSTimeStamp, string Subject, string Notation, NoteType NoteType,\n"
" //string Company, string NoteCategory, ref OracleConnection Connection)\n"
" string Company, string NoteCategory, string DocumentName, ref SqlConnection Connection)\n"
" {")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")