import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*(\\S*)\\({1}.*ref\\s*SqlConnection";
final String string = "public static bool InsertNote(string TableName, string TableKey, string DocType, string InsuredKey, string SubmissionKey,\n"
+ " string Staff, string DefaultAction, string DisplayKey, FileType FileType, string IFSFileName,\n"
+ " string IFSFolder, string IFSTimeStamp, string Subject, string Notation, NoteType NoteType,\n"
+ " //string Company, string NoteCategory, ref OracleConnection Connection)\n"
+ " string Company, string NoteCategory, string DocumentName, ref SqlConnection Connection)\n"
+ " {";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}