#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(This is some header \d+)[\s\S]+?^(Repeated item \d+)\s*^(Repeated item.*)[\s\S]+?(Repeated item \d+)\s*^(Repeated item.*)"
Local $sString = "This is some header 1" & @CRLF & _
"" & @CRLF & _
"nonsense text 1" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Repeated item 1" & @CRLF & _
"Repeated item 1 Data" & @CRLF & _
"" & @CRLF & _
"nonsense text 1" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Repeated item 2" & @CRLF & _
"Repeated item 2 Data" & @CRLF & _
"" & @CRLF & _
"This is some header 2" & @CRLF & _
"" & @CRLF & _
"nonsense text 1" & @CRLF & _
"" & @CRLF & _
"Repeated item 1" & @CRLF & _
"Repeated item 1 Data" & @CRLF & _
"" & @CRLF & _
"nonsense text 1" & @CRLF & _
"" & @CRLF & _
"Repeated item 2" & @CRLF & _
"Repeated item 2 Data"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")