// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(This is some header \d+)[\s\S]+?^(Repeated item \d+)\s*^(Repeated item.*)[\s\S]+?(Repeated item \d+)\s*^(Repeated item.*)").unwrap();
let string = "This is some header 1
nonsense text 1
Repeated item 1
Repeated item 1 Data
nonsense text 1
Repeated item 2
Repeated item 2 Data
This is some header 2
nonsense text 1
Repeated item 1
Repeated item 1 Data
nonsense text 1
Repeated item 2
Repeated item 2 Data";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}