import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(This is some header \\d+)[\\s\\S]+?^(Repeated item \\d+)\\s*^(Repeated item.*)[\\s\\S]+?(Repeated item \\d+)\\s*^(Repeated item.*)";
final String string = "This is some header 1\n\n"
+ "nonsense text 1\n\n\n"
+ "Repeated item 1\n"
+ "Repeated item 1 Data\n\n"
+ "nonsense text 1\n\n\n"
+ "Repeated item 2\n"
+ "Repeated item 2 Data\n\n"
+ "This is some header 2\n\n"
+ "nonsense text 1\n\n"
+ "Repeated item 1\n"
+ "Repeated item 1 Data\n\n"
+ "nonsense text 1\n\n"
+ "Repeated item 2\n"
+ "Repeated item 2 Data";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}