package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(This is some header \d+)[\s\S]+?^(Repeated item \d+)\s*^(Repeated item.*)[\s\S]+?(Repeated item \d+)\s*^(Repeated item.*)`)
var str = `This is some header 1
nonsense text 1
Repeated item 1
Repeated item 1 Data
nonsense text 1
Repeated item 2
Repeated item 2 Data
This is some header 2
nonsense text 1
Repeated item 1
Repeated item 1 Data
nonsense text 1
Repeated item 2
Repeated item 2 Data`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}