using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"i2\d{3}-\d{1,3}$";
string input = @"i2123-1
i2121-20
i2111-331
i2111
i21111
i2111-1141";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}