package main
import (
    "regexp"
    "fmt"
)
func main() {
    var re = regexp.MustCompile(`(?m)i2\d{3}-\d{1,3}$`)
    var str = `i2123-1
i2121-20
i2111-331
i2111
i21111
i2111-1141`
    
    for i, match := range re.FindAllString(str, -1) {
        fmt.Println(match, "found at index", i)
    }
}