// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)i2\d{3}-\d{1,3}$").unwrap();
let string = "i2123-1
i2121-20
i2111-331
i2111
i21111
i2111-1141";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}