import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "i2\\d{3}-\\d{1,3}$";
final String string = "i2123-1\n"
+ "i2121-20\n"
+ "i2111-331\n"
+ "i2111\n"
+ "i21111\n"
+ "i2111-1141";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}