#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<div>\s*\n\s*.*?<p class=.*?>(.*?)<\/p>\s*\n\s*.*?\s*\n\s*(?=(\<a class=\"a\"\>))"
Local $sString = "<div>" & @CRLF & _
" <p class="match"> this sentence should match </p> " & @CRLF & _
" some text" & @CRLF & _
" <a class="a"> some text </a> " & @CRLF & _
"</div>" & @CRLF & _
"<div> " & @CRLF & _
" <p class="match"> this sentence shouldnt match</p> " & @CRLF & _
" some text" & @CRLF & _
" <a class ="b"> some text </a> " & @CRLF & _
"</div>" & @CRLF & _
"<div>" & @CRLF & _
" <p class="match"> this sentence should match </p> " & @CRLF & _
" some text" & @CRLF & _
" <a class="a"> some text </a> " & @CRLF & _
"</div>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)