# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<div>\s*\n\s*.*?<p class=.*?>(.*?)<\/p>\s*\n\s*.*?\s*\n\s*(?=(\<a class=\"a\"\>))"
test_str = ("<div>\n"
" <p class=\"match\"> this sentence should match </p> \n"
" some text\n"
" <a class=\"a\"> some text </a> \n"
"</div>\n"
"<div> \n"
" <p class=\"match\"> this sentence shouldnt match</p> \n"
" some text\n"
" <a class =\"b\"> some text </a> \n"
"</div>\n"
"<div>\n"
" <p class=\"match\"> this sentence should match </p> \n"
" some text\n"
" <a class=\"a\"> some text </a> \n"
"</div>")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.